Résoudre les problèmes de vos flux de travail automatisés Business Central
Lorsque vous connectez Business Central à Power Automate pour créer des flux de travail automatisés, vous pourriez rencontrer des messages d'erreur. Cet article fournit des solutions suggérées aux problèmes récurrents.
Le flux ne s'exécute pas sur tous les enregistrements créés ou modifiés
Problème
Si un événement crée ou modifie de nombreux enregistrements, le flux ne s'exécute pas sur certains ou tous les enregistrements.
Cause possible
Actuellement, il existe une limite sur le nombre d'enregistrements qu'un flux peut traiter. Si plus de 1 000 enregistrements sont créés ou modifiés dans un délai de 30 secondes, le flux n'est pas déclenché.
Remarque
Remarque:
Pour les développeurs, le déclenchement du flux se fait via des notifications webhook, et cette limitation est due à la façon dont le connecteur Business Central gère les notifications de collection notifications. Pour en savoir plus, consultez Utilisation des webhooks dans Dynamics 365 Business Central dans l'aide aux développeurs et aux administrateurs.
Erreur « La réponse du service Business Central est trop volumineuse »
Problème
Lors de l'utilisation d'une action qui interagit avec des enregistrements (comme Créer un enregistrement (V3) et Obtenir un enregistrement (V3)), Power Automate pourrait afficher une erreur similaire à celle-ci :
La réponse du service Business Central est trop volumineuse
Cause possible
Même si Business Central n'a pas de limite définie sur la taille des enregistrements renvoyés par les API, le connecteur Dynamics 365 Business Central pour Power Automate ne peut gérer que des enregistrements jusqu'à 8 Mo.
Toutes les API Business Central fournies par Microsoft renvoient des enregistrements en dessous de cette limite, mais les API fournies par des partenaires pourraient ne pas le faire. Si vous voyez une erreur « La réponse du service Business Central est trop volumineuse », contactez le partenaire qui a créé l'API que vous utilisez.
Erreur « Ensemble d'entités introuvable »
Problème
Lorsque vous créez un nouveau flux Power Automate à l'aide d'un déclencheur d'approbation Business Central, tel que Lorsqu'une approbation de document achat est demandée, vous pourriez obtenir un message d'erreur similaire à celui-ci :
Ensemble d'entités introuvable : \<name\>
L'espace réservé, \<name\>, est le nom de service du service web manquant, tel que workflowWebhookSubscriptions ou de workflowPurchaseDocumentLines.
Cause possible
L'utilisation de Power Automate pour les approbations nécessite que certains objets de page et de codeunit soient publiés en tant que services web. Par défaut, la plupart des objets requis sont publiés en tant que services web. Mais dans certains cas, votre environnement a peut-être été personnalisé de sorte que ces objets ne sont plus publiés.
Correction
Accédez à la Services web page et assurez-vous que les objets suivants sont publiés en tant que services web. Il devrait y avoir une entrée dans la liste pour chaque objet, avec la case Publié cochée.
| Type d'objet | ID objet | Nom d'objet | Nom de service |
|---|---|---|---|
| Codeunit | 1544 | WorkflowWebhookSubscription | WorkflowActionResponse |
| Page | 6408 | workflowCustomers | workflowCustomers |
| Page | 6406 | workflowGenJournalBatches | workflowGenJournalBatches |
| Page | 6407 | workflowGenJournalLines | workflowGenJournalLines |
| Page | 6409 | workflowItems | workflowItems |
| Page | 6405 | Entité ligne document achat | workflowPurchaseDocumentLines |
| Page | 6404 | workflowPurchaseDocuments | workflowPurchaseDocuments |
| Page | 6403 | Entité ligne document vente | workflowSalesDocumentLines |
| Page | 6402 | workflowSalesDocuments | workflowSalesDocuments |
| Page | 6410 | workflowVendors | workflowVendors |
| Page | 831 | workflowWebhookSubscriptions | workflowWebhookSubscriptions |
Remarque
Remarque:
La Nom de service La valeur doit être exactement telle qu'indiquée dans le tableau. Ne modifiez pas et ne traduisez pas le nom du service.
Pour en savoir plus sur la publication de services web, consultez Publier un service web.
Informations connexes
Utiliser les flux Power Automate dans Business Central
Flux de travail
Configurer les flux de travail automatisés
Activer les flux instantanés
Gérer les flux Power Automate
Trouvez des modules d'apprentissage en ligne gratuits pour Business Central ici